Team Cyclops Forums  

Go Back   Team Cyclops Forums > CycloDS Evolution Discussion > Evolution BETA Firmware

Reply
 
Thread Tools Display Modes
  #1  
Old 11-04-2008, 07:23 AM
Evolution's Avatar
Evolution Evolution is offline
TeamCyclops Staff
 
Join Date: Sep 2007
Posts: 581
Default GBA issues with 1.5 BETA 4

It seems that some people are still having issues with the integrated GBA support in the latest BETA firmware. Rather than scanning through the forum looking for posts relating to this in various different threads, I would prefer if anybody having issues could simply post them in this thread in order to create one consolidated bug report. If you are using the LATEST BETA firmware (currently v1.5 BETA 4) and are having problems with the integrated GBA support, please reply to this thread and provide the following information:
  • Your slot 2 hardware (CycloDS, EZ3in1 OLD, EZ3in1 NEW)
  • The specifics of the problem you're having - which games exhibit problems and what exactly is going wrong (can not save, etc). If some games work while others do not, please include both working and non-working games in your description.
  • Does rumble or the Opera auto-patch work?
  • Have you previously flashed a GBA game to NOR?
  • Are the same problems encountered if you use GBAExpLoader?
Thanks. Hopefully we can get this resolved once and for all
Reply With Quote
  #2  
Old 11-04-2008, 01:08 PM
Raskull's Avatar
Raskull Raskull is offline
Senior Member
 
Join Date: Apr 2008
Location: Tampa, FL
Posts: 738
Default

The only problem that I have experienced is that Kingdom Hearts will not work with a SAV file created by GBAExploader.

I am using an EZ3in1 NEW and Kingdom Hearts continues to work with GBAExploader (from a backed up, uncorrupted SAV).
__________________
Nintendo DS Lites (Onyx, Gold Legend of Zelda Limited Edition)
CycloDS Evolutions (Black, Hardware v1.1, Firmware 1.53)
Sandisk 8GB MicroSDHCs (Class 4), EZ Flash 3-in-1s (Black, New Chipset
)
Reply With Quote
  #3  
Old 11-04-2008, 03:09 PM
impizkit's Avatar
impizkit impizkit is offline
Senior Member
 
Join Date: Jun 2008
Posts: 380
Default

The issues that I have are with both using the integrated GBA support and exploader. The games load and run perfectly using either method. The problem is with saves. It seems that no matter what game I use, the saves rarely work, even if flashed into NOR. I havent even tried the rumble function because I dont really care about it. I would believe that it is an issue with my EZ 3-in-1. I have the new version and just baught it about 2 weeks ago. Since it is always saves that give me problems no matter if I use the integrated support or exploader I think it is the 3-in-1. I cant say for sure because I dont know how to test the battery to see if it could be bad. I have taken it apart and everything is connected properly. I may just buy a new 3-in-1 to see if that helps. Also, to give a bit more information, I have not used gba support until 1.5B4 and tried the integrated first because exploader never appealed to me. Since exploader didnt work either I think it is an issue with my slot 2 card. Any suggestions would be greatly appreciated.
Reply With Quote
  #4  
Old 11-05-2008, 05:11 PM
pspgeek pspgeek is offline
Junior Member
 
Join Date: Mar 2008
Posts: 4
Default

The issues that I have are that after playing a game for a while, the integrated support stops backing up the save. Also homebrew that use rumble only work after running a DS game that uses rumble and doing a reset or enabling rumble with GBAExploader.
Reply With Quote
  #5  
Old 11-05-2008, 07:12 PM
ninjafan101 ninjafan101 is offline
Member
 
Join Date: Jun 2008
Posts: 35
Default

Here is my post from the 1.5 BETA 4 topic. Yes rumble and opera auto patch works, I have previously flashed a game to NOR ( I usually always have one stored in NOR), and the same problem occurs with GBAExploader.
Quote:
With the GBA game DragonBall Z Buu's Fury, as soon as I got to the grand kai's house for the tournament (fairly early into the game) it pops up: "The game cannot be played on this hardware." Could this be fixed before 1.5 release? I'm using hardware version 1.1, 1.5 BETA 4, ezflash 3 in 1 new chip set. I also have the Battery Saver on, but I'm not sure if that affects GBA games.

Last edited by ninjafan101; 11-05-2008 at 07:16 PM.
Reply With Quote
  #6  
Old 11-05-2008, 10:10 PM
halo4244 halo4244 is offline
Junior Member
 
Join Date: Apr 2008
Posts: 28
Default gba save

the super monkey ball jr. wont save at all and iv tried both methods
Reply With Quote
  #7  
Old 11-05-2008, 11:19 PM
f00had's Avatar
f00had f00had is offline
Senior Member
 
Join Date: Nov 2007
Location: England
Posts: 424
Send a message via MSN to f00had
Default

Quote:
Originally Posted by ninjafan101 View Post
Here is my post from the 1.5 BETA 4 topic. Yes rumble and opera auto patch works, I have previously flashed a game to NOR ( I usually always have one stored in NOR), and the same problem occurs with GBAExploader.
I remember using a patch to get past that bit on an emulator, perhaps you need to use the patch too.
__________________

Turquoise Nintendo DS Lite
Batch 3 White CycloDSEvolution (FW 1.5B4)
Taiwanese 2GB Sandisk microSD
NEW type White EZ Flash 3-in-1
Reply With Quote
  #8  
Old 11-10-2008, 11:03 PM
noob15's Avatar
noob15 noob15 is offline
Member
 
Join Date: Dec 2007
Posts: 84
Default

Quote:
Originally Posted by ninjafan101 View Post
Here is my post from the 1.5 BETA 4 topic. Yes rumble and opera auto patch works, I have previously flashed a game to NOR ( I usually always have one stored in NOR), and the same problem occurs with GBAExploader.
um ok if you are asking if the problem in buu's fury is the firmware that is incorrect u can patch the gba rom with this http://gbatemp.net/index.php?download=2495 it should let you pass the tornament now.

ps. i m really tired at the moment so if i read ur quetion wronge srry
__________________
DS Lite Onyx
not flashed
EZ Flash 3-in-1 Lite, black
cycle evolution black H.W 1.1 w fw1.51
6gb micrsodshc
Reply With Quote
  #9  
Old 11-09-2008, 05:16 PM
stanleypetersen stanleypetersen is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Default Mario kart

Mario kart super circuit works very slow, characters disapear and sound have bugs too.

My slot 2 card is an Ewin expansion pack.
The game works well with GBA expLoader.

Last edited by stanleypetersen; 11-09-2008 at 05:21 PM.
Reply With Quote
  #10  
Old 11-11-2008, 07:45 PM
MechaBouncer's Avatar
MechaBouncer MechaBouncer is offline
Senior Member
 
Join Date: Aug 2007
Location: Michigan
Posts: 105
Default

Quote:
Originally Posted by Evolution View Post
*Your slot 2 hardware (CycloDS, EZ3in1 OLD, EZ3in1 NEW)
EZ-Flash 3-in-1 OLD version from over a year ago in August. I bought it with my CycloDS Evolution, which I believe was a revised white model from the second batch right around the time the black Evo's first came out.

Quote:
Originally Posted by Evolution View Post
*The specifics of the problem you're having - which games exhibit problems and what exactly is going wrong (can not save, etc). If some games work while others do not, please include both working and non-working games in your description.
I can launch my games just fine to PSRAM and NOR, but none of them will save. This includes, but is not limited to:
Metroid Fusion
Metroid Zero Mission
Rock 'n' Roll Racing
Kirby: Nightmare in Dream Land
Kingdom Hearts: Chain of Memories

It doesn't make a difference if I use PSRAM or NOR to launch them. It also doesn't matter if I launch from the Evo's menu or from GBA ExpLoader. When launching from the Evo's menu with the normal save settings, no errors show up at all, but it still doesn't retain the save. However, if I launch with the alternate save setting enabled, I used to get an error stating "There has been a save memory related error. ROM save memory support is disabled for this session. Please see the CycloDS website for more information." However, now I'm not even getting that.

Quote:
Originally Posted by Evolution View Post
*Does rumble or the Opera auto-patch work?
Yes, both rumble and the Opera auto-patch work properly.

Quote:
Originally Posted by Evolution View Post
*Have you previously flashed a GBA game to NOR?
Yes and I had Kindom Hearts: CoM flashed to it when I updated the Evo's firmware. I typically have used GBA ExpLoader because it's compatible with launching from the DS's firmware like a regular GBA game.

Quote:
Originally Posted by Evolution View Post
*Are the same problems encountered if you use GBAExpLoader?
Yes. If I try launching from GBA ExpLoader, I get an error when it first starts up asking if it can set the Slot2 expansion pack for use with it. Then it says that the "Current SRAM Save" is "Empty or new state". I even tried turning off GBA support in the Evo's XML file, but GBA ExpLoader still acts the same.
__________________
-MechaBouncer out
Cobalt/Black NDSL
White CycloDS Evolution (firmware 1.5)
Kingston SD-C02G JAPAN 2GB MicroSD
EZFlash 3-in-1

Last edited by MechaBouncer; 11-11-2008 at 08:45 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:01 AM.